I have a question on threads....

Company specific discussions and announcements.

Moderators: [email protected], Kenny_SilencerCo

Post Reply
DirtyHandsRob
Member
Posts: 44
Joined: Sat Oct 13, 2012 11:35 am
Location: Lincoln, NE

I have a question on threads....

Post by DirtyHandsRob » Fri Oct 04, 2013 8:16 am

I have a Warlock II that is going on my hosts, which are: Savage FV-SR, M&P-22, 22LR SBR AR.

Savage threads are .475 and the Warlock threads down the shoulder and engages the O-ring.

M&P 22 thread adapter is .400 and threads down to the shoulder, but just shy of the O-ring.

22LR AR15 has threads of .400. it was cut down by redtazdog (which did amazing job), however when i thread on the Warlock's mount, it becomes really tight and stops about .080 from the shoulder of the barrel. but here's the funny thing... i have a couple of thread protectors, both .400. one is from the M&P 22 and one is an SWR O-ring protector. they thread on to the AR barrel perfect.

I have tried to clean all of the threads and all hosts and the mount, so what could be holding up my mount from screwing on all the way? And since my AR has the suppressor under the handguards, I unthreaded the can, but left the mount on the barrel. i had to take off the FF handguards to get the mount... that's when i figured, something must be wrong. any ideas????

i can post pics if needed.


ETA: redtazdog re-threaded it and it fits amazing!
Last edited by DirtyHandsRob on Wed Oct 16, 2013 7:29 am, edited 1 time in total.

User avatar
redtazdog
Elite Member
Posts: 2432
Joined: Sat Jun 23, 2007 11:30 am
Contact:

Re: I have a question on threads....

Post by redtazdog » Fri Oct 04, 2013 9:36 am

DirtyHandsRob wrote:I have a Warlock II that is going on my hosts, which are: Savage FV-SR, M&P-22, 22LR SBR AR.

Savage threads are .475 and the Warlock threads down the shoulder and engages the O-ring.

M&P 22 thread adapter is .400 and threads down to the shoulder, but just shy of the O-ring.

22LR AR15 has threads of .400. it was cut down by redtazdog (which did amazing job), however when i thread on the Warlock's mount, it becomes really tight and stops about .080 from the shoulder of the barrel. but here's the funny thing... i have a couple of thread protectors, both .400. one is from the M&P 22 and one is an SWR O-ring protector. they thread on to the AR barrel perfect.

I have tried to clean all of the threads and all hosts and the mount, so what could be holding up my mount from screwing on all the way? And since my AR has the suppressor under the handguards, I unthreaded the can, but left the mount on the barrel. i had to take off the FF handguards to get the mount... that's when i figured, something must be wrong. any ideas????

i can post pics if needed.
Your threads in the can mount may be too perfect and the threads on the barrel could be too perfect :wink:
I probably cut the threads on the top/large side of the specs as most of the time I do and have never had any problems +
most cans fit a little closer fit on the barrel threads then.
or the thread relief may be just a hair to large and the mount is stopping there.

Send the barrel or upper to me and I will check them real quick if you like

Robert

User avatar
Bendersquint
Industry Professional
Posts: 11359
Joined: Sat Jan 07, 2006 9:19 pm
Location: North Carolina
Contact:

Re: I have a question on threads....

Post by Bendersquint » Fri Oct 04, 2013 10:01 am

Just sounds like the thread pitch is a shy different for each of the hosts.

User avatar
[email protected]
Silent But Deadly
Posts: 180
Joined: Mon Nov 12, 2012 8:37 pm
Location: Utah
Contact:

Re: I have a question on threads....

Post by [email protected] » Fri Oct 04, 2013 12:36 pm

You can either take Red up on his offer or you can send the upper and suppressor in to us and we can look at it for you. Either way is fine with me. If you want us to take care of it call or email me and I will get you an RMA.
Andrew Herbst
Silencerco/SWR
Customer Service
801-417-5384
[email protected]

DirtyHandsRob
Member
Posts: 44
Joined: Sat Oct 13, 2012 11:35 am
Location: Lincoln, NE

Re: I have a question on threads....

Post by DirtyHandsRob » Sat Oct 05, 2013 8:24 am

I think I'll take RTD up on his offer. I'll be sending him a PM. since I just got my suppressor, I don't think I can live without it for now. :D

DirtyHandsRob
Member
Posts: 44
Joined: Sat Oct 13, 2012 11:35 am
Location: Lincoln, NE

Re: I have a question on threads....

Post by DirtyHandsRob » Wed Oct 23, 2013 7:38 am

update: i sent this to RedTazDog. he worked on it and sent it back super quick. the suppressor threads on really slick now. my father-in-law and I tested it out a few days ago and everything worked great!

Post Reply