AAC762SD problem?

Company specific discussions and announcements.

Moderator: SilentMike

Post Reply
BigCountry
New Member
Posts: 2
Joined: Wed Jul 03, 2019 8:36 pm

AAC762SD problem?

Post by BigCountry » Wed Jul 03, 2019 9:00 pm

I recently sent my 762-sd back to AAC because while inspecting my suppressor I noticed that the baffles towards the middle of the suppressor looks to be damaged. I received a phone call from them today telling me that it is indeed normal and that they are supposed to look this way. I don't believe it. Can anyone else verify that the middle 5 baffles are indeed a irregular hole?

https://drive.google.com/file/d/1-2d_hO ... p=drivesdk

https://drive.google.com/file/d/1--nUjt ... p=drivesdk

a_canadian
Silent But Deadly
Posts: 1105
Joined: Fri Oct 11, 2013 4:09 pm

Re: AAC762SD problem?

Post by a_canadian » Fri Jul 05, 2019 4:50 am

I haven't read the whole long thread, but this post from Mike at AAC in 2012 seems to answer your questions:
viewtopic.php?t=82685#p755564

BigCountry
New Member
Posts: 2
Joined: Wed Jul 03, 2019 8:36 pm

Re: AAC762SD problem?

Post by BigCountry » Fri Jul 05, 2019 1:06 pm

Thanks for the link. Mine is a new er 762SDN that has an all inconel baffle stack. But by the way he talks this is normal. It's kind of funny when I sent the same pictures to AAC, they said it didn't look right and for me to send my can to them. Now they're saying everything is fine. I just wanted to verify with somebody else that this is indeed normal. Thanks again so much for your help.

DrDremel
Senior Silent Operator
Posts: 133
Joined: Mon Jan 02, 2006 8:10 pm
Location: Ortonville, MI

Re: AAC762SD problem?

Post by DrDremel » Thu Aug 22, 2019 8:12 am

The baffles are stacked this way and it is normal. I have 15,000 rounds through mine and it is going strong.

Post Reply